System migration

Incident Report for SuperHumanX

Update

We are continuing to investigate this issue.
Posted Jul 08, 2024 - 12:43 PDT

Update

!! BE ADVISED !! The tracking client for `win64` is now available to be updated. Please do so as soon as you can.
Posted Jul 08, 2024 - 11:20 PDT

Update

We are continuing to investigate this issue.
Posted Jun 25, 2024 - 09:49 PDT

Investigating

We are currently investigating this issue.
Posted Jun 25, 2024 - 09:33 PDT
This incident affects: Chat and Tracking client.